What Versions of Point of Sale (POS) Are Compatible With Microsoft Windows Vista?

The following versions of QuickBooks Point of Sale (POS) are compatible with Microsoft Windows Vista:

  • QuickBooks POS Basic 6.0 and 9.0
  • QuickBooks POS Pro 6.0 and 9.0

Users of older versions of QuickBooks POS need to upgrade to the latest version in order to install and use QuickBooks on Vista in a supported environment.

While POS 5.0 and earlier versions are not Vista compatible and not supported, Intuit offers more specifics and these comments to users of POS 5.0 and earlier versions considering Vista.

If you need to upgrade, you can review detailed product comparisons as well as obtain discounts and free shipping by visiting the links on our Buy QuickBooks page.

Vote This Post DownVote This Post Up (No Ratings Yet)
Loading...